Back to overview
Degraded

We have noticed a spike in out database connections

Sep 15, 2022 at 1:28pm UTC
Affected services
Custom Domains

Resolved
Sep 15, 2022 at 1:58pm UTC

Our connections are back to normal and we are investigating the root cause internally. Thank you for your patience.

Created
Sep 15, 2022 at 1:28pm UTC

We are investigating this currently, will post an update as soon as we fix this. Thank you for your patience.