Back to overview
Downtime

SSL certificate and Domain Alias Processer are having downtime

Oct 13, 2022 at 8:10am UTC

Resolved
Oct 13, 2022 at 8:15am UTC

The services are up again. We will continue to investigate this internally.
Thank you for your patience.

Created
Oct 13, 2022 at 8:10am UTC

We are currently investigating an issue with our SSL certificate generator