Back to overview
Downtime

SSL certificate and Domain Alias Processer are having downtime

May 24, 2022 at 11:54pm UTC

Resolved
May 25, 2022 at 12:19am UTC

Both the background services are UP. We will continue to monitor. Thank you for your patience!

Updated
May 25, 2022 at 12:06am UTC

We have identified issues with our service provider and replaced with new instances. We will continue to monitor and investigate further. Thank you for your patience.

Created
May 24, 2022 at 11:54pm UTC

We are currently investigating the issues